SonyUserforum

SonyUserforum (https://www.sonyuserforum.de/forum/index.php)
-   Blitzgeräte und Beleuchtung (https://www.sonyuserforum.de/forum/forumdisplay.php?f=26)
-   -   Adapter 5400xi/hs -> 7D - User mit Lötkolben gesucht ;-) (https://www.sonyuserforum.de/forum/showthread.php?t=31506)

Sebastian W. 19.10.2006 15:24

Zitat:

Zitat von sebi
Wie hast Du das denn getestet? Grundsätzlich ist bei der 7D/5D/Alpha bei jeder Art von Blitzerei ein Vorblitz nötig.

Zitat:

Zitat von sebi
Der Unterschied bei ADI besteht darin, daß in die Bestimmung der richtigen Leuchtdauer auch die Entfernungsinformationen einbezogen werden. Gerade bei ADI ist also immer ein Vorblitz nötig, auch bei analogen Kameras.

Ich habe den ADI-Modus getestet indem ich ein graues zentrales Hauptmotiv fest aufgestellt habe, dessen Helligkeit ich im Photoshop leicht messen kann. Hinter das Hauptmotiv stellte ich weiße Pappe, graue Pappe, Lee-Reflexfolie mit Alu-Beschichtung oder nichts, so daß der Vorblitz unreflektiert in den Nachthimmel schoss. Ich habe automatisch und manuell fokussiert, so daß der Kamera kein AF-Feld bekannt war das sie bei einer TTL-Messung hätte bevorzugen können. Das Hauptmotiv war immer gleich belichtet. Daher nehme ich an, daß der Vorblitz zwischen der Nahstellgrenze und ausreichend weit vor unendlich keine Auswirkung hat und überflüssig sein könnte. Da ich meist in diesem Entfernungsbereich blitze, wäre ein vorblitzloser ADI-Modus ein Segen. Bei ADI, einem D-fähigen Objektiv und in üblichem Entfernungsbereich beeinflussen die Reflexionseigenschaften des Motives die Blitzbelichtung wie im oberen Beispiel nicht, es wird ausschließlich nach Leitzahl geblitzt. Bei mindestens einer jüngeren Analogkamera von Minolta war ADI-Blitzen ohne Vorblitz möglich.

Der Versuchsaufbau ähnelte grob dem Beispiel V in diesem Posting und ist lediglich etwas auf die Spitze getrieben.

mike63 19.10.2006 16:11

Hallo sebi,

ich gratuliere Dir zu Deinem Erfolg. :top: :top: :top:

Verfolgst Du die Idee eines Bausatzes mit entsprechend programmiertem EPROM weiter, wenn Du wieder etwas Luft hast?

Ich weiss sonst nicht wie ich bei meinen "Programmierkünsten" und ohne die entsprechende Ausrüstung meinen 5400 HS umbauen soll. :oops: :oops:

Viele Grüsse

Mike

Hademar2 19.10.2006 16:47

Zitat:

Zitat von mike63
Hallo sebi,

ich gratuliere Dir zu Deinem Erfolg. :top: :top: :top:

Verfolgst Du die Idee eines Bausatzes mit entsprechend programmiertem EPROM weiter, wenn Du wieder etwas Luft hast?

Ich weiss sonst nicht wie ich bei meinen "Programmierkünsten" und ohne die entsprechende Ausrüstung meinen 5400 HS umbauen soll. :oops: :oops:

Viele Grüsse

Mike

So wird es vielen ergehen, mir natürlich auch! Bin mal gespannt, wie das hier alles weiter geht.

Könnte ja auch sein, dass jemand anders diese Bastelarbeiten übernimmt!

Snooper 19.10.2006 17:26

Hey Sebi,

hab' ich es richtig verstanden, dass ich deine Schaltung hier, in das Blitzgerät einbauen, die Leitungen anzapfen und anschliessend mit der Firmware beschreiben kann, da der Attiny durch die Batterien mit genügend Strom versorgt wird? Ist das ISP??*ganzdämlichfrag* :oops:


Viele Grüße,
Dan

sebi 19.10.2006 18:25

Hallo,

die Idee mit dem vorprogrammierten Chip ist noch nicht gestorben, aber dazu gibt es frühestens was Neues, wenn a) die Tests von Peter positiv ausfallen und b) die restlichen 3 Blitze, die hier liegen, umgebaut und ebenfalls für gut befunden wurden. Dann werde ich wohl mal eine Leiterplatte machen lassen und ein paar Sets bestücken.

@Snooper:
Grundsätzlich funktioniert das Programmieren auch im eingebauten Zustand, allerdings werden einige der Leitungen vom Blitz zu sehr belastet. Das bedeutet, daß man erst den Chip an den Parallelport-Adapter anschließen und programmieren muß und ihn dann in die Kamera einsetzt. Dafür ist dann das Kontaktieren einfacher - wer hat schon einen Minolta-Blitzschuh lose rumfliegen?! ;-)

Sebi

Snooper 19.10.2006 18:31

@sebi
hehe, danke Dir :)

Gruß,
Dan

sebi 19.10.2006 20:01

Hallo allerseits,

Hier (flashconv-0.6.tar.gz) gibt´s die letzte Version der Software zum Download. Allerdings habe ich diese mit dem 5400XI nicht erfolgreich getestet - es gibt zu viele Fehlbelichtungen. Irgendwo liegt da der Hase im Pfeffer. Für Umbauten des 5400XI sollte also die Version flashconv-0.4.tar.gz verwendet werden.

Ich muß mal sehen, wann ich dazu komme, das zu vereinheitlichen. Derzeit sehe ich den Wald vor lauter Bäumen nicht - so verschieden scheinen mir die Versionen gar nicht... :shock: Nach ein paar Tagen Pause (mein 5400er kommt natürlich mit :? ) geht das bestimmt besser.

Sebi

edroony 19.10.2006 22:16

Hallo Sebi,
wünsche Dir eine erholsame Zeit, hasst Du Dir absolut verdient ;) RESPEKT für die geleistete Grundlagenforschung und dann noch in den Feldversuch umgesetzt WAHNSINN. :top: :top: :top:
Falls es mal eine KIT Version mit "fertiger" Platine gibt *lechtz* würde ich sie gerne in einem 5400XI einsetzten!!!

Viele Grüße
Andreas
(EdRoony)

PS: Mal eine dumme Frage am Rande, würde der "gepimpte" Blitz auch noch an einer Analogen Dynax 8000i oder 7 funktionieren???

sebi 20.10.2006 23:41

`N abend zusammen,

Es gibt Neuigkeiten. Peter hat heute seinen Blitz zurückerhalten und erste Tests gemacht. Die Ergebnisse sind gemischt - es funktioniert grundsätzlich auch mit einer anderen 7D, allerdings nicht immer :roll: Die Software hat ganz offensichtlich noch ein paar Bugs. Dafür sind die Ergebnisse - so es funktioniert - wohl sehr ordentlich. Aber ich will Peters Erfahrungsbericht nicht vorgreifen ;-)

Einige der Bugs sollten bereits behoben sein - ich habe mich heute drangesetzt und ein bißchen an der Vereinheitlichung der Software gebastelt. Dafür mußte ich die Software erstmal wieder zur Zusammenarbeit mit dem XI überreden - ich spiele ein bißchen Ping-Pong. Und ich habe mich selbst zum Testkaninchen gemacht - am Wochenende steht eine kleine Feier an, dort werde ich mit der großen Schwarzen und einem umgebauten 5400XI antreten.

@edrooony: Er sollte auch an einer analogen funktionieren. Getestet habe ich´s bisher nur "trocken" - mit einer 7xi ohne Film... ;-) Die Schaltung ist so konzipiert, daß sie die Kommunikation zwischen Blitz und Kamera mitliest und nur eingreift, wenn´s notwendig ist. Das ist zum einen das Auslösen des Vorblitzes und zum Zweiten die Einstellung der Blitzdauer, nachdem sie eine gültige Zeit erhalten hat. Da bei analogen Kameras beides nicht vorkommt, sollte sich die Schaltung neutral verhalten und die Kommunikation nicht stören. Aber wie gesagt - ich habe nur die 7xi drangehängt, der Blitz hat ausgelöst und nach der Aufnahme blinkte "OK" am Blitz und an der Kamera....


So long,
Sebi

PS: flashconv-0.7 - diesmal mit dem HS [s:859289b471]gar nicht[/s:859289b471] nur kurz getestet - hat funktioniert... :oops:

neo2006 20.10.2006 23:57

Wohl dann, dass bald ein wahres Blitzgewitter herein bricht. :shock: :P ;)

Äh.. nein nicht über Dich Sebi (ich will es zumindest nicht hoffen :shock: ), doch wohl in absehbarer Zeit bei uns mit unseren Umgebauten Blitzen :top:

Gruß Roland

PeterHadTrapp 21.10.2006 09:24

Erster Betabericht
 
Da isser der Erfahrungbericht von Eurem Betatester.

Gestern habe ich meinen Blitz von Sebi bekommen.

Bltz: 5400 HS

Mit feuchten Händen auf die D7d gestöpselt und losgeblitzt.

  • :arrow: Die Funktionen laufen perfekt, wenn sie laufen.
    - Der Blitz meldet sich richtig an, wird erkannt.
    - Der Vorblitz kommt, die Anzeige auf der Rückseite ist korrekt.
    - Der Zoom fährt mit, die Reichweitenangaben stimmen, HSS-Betrieb klappt, muss aber manuell aktiviert werden (ist beim 5400er wohl so)

    :arrow: Direktes Blitzen, indirektes Blitzen, Wireless --> alles bestens
    - wenn man das gleiche Motiv indirekt blitzt sieht man sofort, dass er stärker feuert.
    - bei direkten Blitzen gefällt mir die Dosierung besser als beim 5600er :shock:
    - auch mein neuer Bastel-Bouncer liefert mit dem 5400 sehr schöne Ergebnisse, er blickt also auch die "halbindirekten Sonderwege" --> die Vorblitzmessung wird absolut perfekt ausgewertet
    - Wireless-Betrieb funzt einwandfrei, meldet sich immer mit Kanal 1 (Blitz auffe Cam, Menue-WL-Modus einstellen - Blitz ab (Anzeige am Blitz geht auf WL Ch1 - internen auf - rotes Licht am blitz blinkt - Foto --> passt.

    :arrow: Blitzbelichtungskorrekturen werden sauber umgesetzt.
    - die Verwendung der Blitzbelichtungskorrektur liefert nachvollziehbare adäquate Veränderungen in der Ausleuchtung - prima .

    :arrow: Die Belichtung ist ausgewogen und richtig - keinerlei Anpassungsprobleme
    - das war für Sebi ja eine interessante Sache, da die 5600er ja fast alle auf die einzelnen Cams eingemessen werden mussten, ob sich die an seiner Cam gefundenen Werte auch an einer anderen D7d als stimmig erscheinen - kurzum: das tun sie. Wenn die Belichtung gemessen wird und stimmt, dann ist sie super.

Soweit so gut. kommen wir zum ABER...
Wir sind eben noch in der "Beta-Phase"und erwartungsgemäß hakt und knirscht es noch ein Wenig im Detail.

Im Einzelnen verschluckt sich die Software im Mikrocontroller oder nimmt sich Pausen.
  • :arrow: Reflektor verschwenken
    - wenn ich den Reflektor nach oben schwenke zum Bouncen - alles O.K..
    - wenn ich ihn dann wieder zurückschwenke, geht der ATtiny in die Frühstückspause und der Blitz baller nur noch mit voller Leistung, macht auch keinen Vorblitz mehr (deswegen nehme ich an, dass der AT dann seine Funktion einstellt.
    - Wenn ich dann den Blitz ein- und ausschalte passt es danach wieder.
    Dieser Fehler ist reproduzierbar und tritt bei 80% der Versuche auf.

    :arrow: Fehler beim automatischen Ausschalten
    Wenn ich den Blitz vergesse auszuschalten (egal ob auf der Cam oder abmontiert und hingelegt) dann begibt er sich nach ca. 15 Minuten in einen uneindeutigen Zustand und fängt irgendwann an immer wieder abzublitzen. Wenn er in diesem Zustand ist, reagiert er auf keine Tasten oder Knöpfe mehr, sondern ist nur noch durch entnehmen der Batterien wieder einzukriegen.

    :arrow: Stromversorgung
    Der Blitz verlangt recht volle Rundzellen. Mit meinen -zugegebenermaßen- ausgelutschen 2000er Akkus ging es nur ca. 30 Blitze richtig, danach feuerte er immer häufiger mit voller Leistung, je leerer umso häufiger volles Brett --> neue Batterien rein: alles wieder O.K.

Ich denke diese kleinen Haken und Ösen wird Sebi sicher noch in den Griff bekommen, man kann ganz klar sehen, dass das Prinzip passt.
Die Ergebnisse sind (wenn er nicht hakt und voll schießt) SPITZE, gefallen mir ehrlich gesagt einen Tick besser als das was mein 5600er liefert.
Der neigt trotz zweimaliger Einmessung in Bremen immer noch gerne dazu zuviel zu blitzen und kriegt von mir (auf meiner Cam) meistens eine -0,5 , insbesondere oft beim bouncen.

http://www.cheesebuerger.de/images/s...hlich/f045.gif http://www.cheesebuerger.de/images/s...hlich/f045.gif http://www.cheesebuerger.de/images/s...hlich/f045.gif Richtig großes Forumskino http://www.cheesebuerger.de/images/s...hlich/f045.gif http://www.cheesebuerger.de/images/s...hlich/f045.gif http://www.cheesebuerger.de/images/s...hlich/f045.gif

PETER

P.S. ich bin heute etwas im Streß, wenn ich dazu komme gibt es noch ein Paar Beispielbilder.

Andreas2406 21.10.2006 11:30

Ich hab mir jetzt gerade mal den gesamten Thread durchgelesen, bin schweißgebadet, und hab' den Sabber im Mundwinkel hängen.

Wenn ich das richtig sehe, dann hast du es geschafft vom 25.9.-19.10, also in knapp 4 Wochen, das Teil in einen Prototyp-Status zu bringen und das ganze als one-man-show. :shock: :shock: :shock: Schreib die Story auf und schick sie zu Sigma, Soligor und wie sie alle heißen, die müssten dir doch sofort ein Job-Angebot machen :top:

Ich hab' da überhaupt keine Worte für... Das ist oberaffengeil !!! :kiss:

Ich hoffe, deine Familie erkennt dich noch, und deine Tochter sagt nicht "Wer ist der Mann zu dir".

Ansonsten meinen allertiefsten Respekt !!!!

Gruß,
A
P.S: Und ich krabbel jetzt mal auf den Speicher, wo aus dem Studium meine Lötausrüstung liegt... Das letzte mal SMD löten ist schon ein paar Jahre her. Endlich ein Ziel für die triste Herbstzeit, jaaaaa

sebi 21.10.2006 16:01

Zitat:

Zitat von Andreas2406
Ich hoffe, deine Familie erkennt dich noch, und deine Tochter sagt nicht "Wer ist der Mann zu dir".

Sieh' Dir mal an, wann meine Postings hier im Forum geschrieben wurden - dann weißt Du, daß mich meine Tochter zwar noch kennt, aber mit mehr oder weniger deutlichen Augenringen :shock:

Nein, alles gut. Und vielen Dank für die Blumen! Mein eigener umgebauter 5400XI zickt auch bisweilen, hier habe ich das Gefühl, als wenn mit dem OmniBounce häufiger Fehlbelichtungen auftreten. Ich überlege derzeit, den ATtiny nach jedem Auslösen eines Hauptblitzes einen kompletten Reset machen zu lassen - ich vermute, daß er manchmal aus der Synchronisation fällt und daher keine ordentliche Blitzzeit hat, wenn der Auslöse-Befehl von der Kamera kommt. Aber ich bleibe natürlich dran.

Zitat:

Zitat von Andreas2406
Schreib die Story auf und schick sie zu Sigma, Soligor und wie sie alle heißen, die müssten dir doch sofort ein Job-Angebot machen

Hehe...auf Jobsuche bin ich derzeit tatsächlich - aber in eine ganz andere Richtung. Kann zufällig jemand einen frischgebackenen Volljuristen in Münster und Umgebung gebrauchen? :cool:

Schönes Wochenende,
Sebi

PeterHadTrapp 21.10.2006 17:07

Vielleicht wäre es mal einen versuch wert, die Transparenz rauszuschmeißen. Wer die Dinger weiterhin an analog einsetzen will, braucht sie nicht umzurüsten.
Offenbar gibt es noch so einige Faktoren, deren Auftreten das ATtiny dazu bewegt seine Arbeit einzustellen, bis es per ein/aus (klappt meistens) oder per Batteriedeckel auf/zu (klappt immer) wieder mitspielt.

Gruß
PETER

P.S. und der 5400er sieht derart schick aus auf der D7d ...

Heinz 22.10.2006 19:03

Sebi,

ich hab zwar immer noch keine Ahnung, was Du das treibst ( ich bin Geisteswissenschaftler), aber die Ergebnisse hauen mich um. Richtig gutes "Forum Kino" das stimmt schon. Mich würden ja so ein bis zwei günstige Zusatzblitz, die man wireless betreiben kann, so richtig gut ins Konzept passen.

Ich wusste übrigens nicht, das man heutzutage solche Fähigkeiten in einem Jura-Studium erwirbt. Die Juristen, die ich kenne, haben alle irgendwie "linke Hände", wenn es nicht gerade um "das Recht haben" geht.

Und es ist schon erstaunlich, wie eine "One-Man Show" ein paar Firmen die Show stielt, die eigentlich ihr Geld mit so was verdienen, was Du da in der Freizeit hinbekommst, wenn Deine Tochter schläft.

WOW!!!

Hochachtungsvoll

Heiner

PS: Wenn ich einen bzw. zwei 5400er mein Eigen nenne, gibt es dann so eine Art Bausatz mit einer detaillierten Anleitung zu diesem Wunderprojekt? Hab einen Kumpel, der könnte das für mich eventuell umsetzen, wenn ich ihn zu einem opulenten Essen einlade.

HH.

sebi 22.10.2006 21:53

Zitat:

Zitat von PeterHadTrapp
Vielleicht wäre es mal einen versuch wert, die Transparenz rauszuschmeißen. Wer die Dinger weiterhin an analog einsetzen will, braucht sie nicht umzurüsten.

Wenn man erstmal außen vor läßt, daß dem mein persönlicher Ehrgeiz entgegen steht ;-), gibt es auch noch andere Faktoren, die das beeinflussen. Der wichtigste ist, daß die Daten für Zoom, Blende, Verschlußzeit etc. ja unangetastet zum Blitz sollen (Reflektorverstellung, Reichweitenanzeige). Die Transparenz ist gewissermaßen eine Folge dessen - der Adapter hört nur zu und setzt nur die Befehle um, die der Blitz alleine nicht kennt (Vorblitz, Timing des Hauptblitzes). Alles andere würde ein komplett anderes Design bedeuten. Auch gäbe es u.U. Probleme mit der Synchronzeit - die Kamera erwartet natürlich, daß der Blitz genau dann auslöst, wenn sie den Befehl dazu gibt. Finge man erst sämtliche Befehle ab, um sie dann neu zu senden, hätte man hier ein Problem.

Zitat:

Zitat von PeterHadTrapp
Offenbar gibt es noch so einige Faktoren, deren Auftreten das ATtiny dazu bewegt seine Arbeit einzustellen, bis es per ein/aus (klappt meistens) oder per Batteriedeckel auf/zu (klappt immer) wieder mitspielt.

Schön gesagt - und stellt mich gleich vor zwei Rätsel. Zum einen habe ich am Wochenende auch ab und zu Fehlbelichtungen erlebt. Gerade wollte ich eine kleine Testreihe machen - ca. 20 Aufnahmen, keine einzige tanzte aus der Reihe. Dabei waren die Akkus nicht gerade voll geladen. Ich weiß also noch nicht genau, wie ich die Fehlbelichtungen provozieren kann.

Das zweite ist "an-aus" oder "Batteriefach auf-zu". Die für den Adapter angezapfte Stromversorgung wird erst abgeschaltet, wenn die LCD-Anzeige komplett erloschen ist (also oben rechts auch NICHT mehr "off" steht). Beim einfachen ein-aus-Schalten rührt sie sich nicht. Das erklärt zwar, warum es einen Unterschied zwischen ein-aus und der Batteriefachgeschichte gibt, nicht aber, warum manchmal ein reines ein-aus reicht. Denn dabei dürfte der Adapter nichteinmal einen Neustart machen (mangels Stromunterbrechung).

Insgesamt tendiere ich nach wie vor zu fehlender Synchronisation. Mal sehen ob ich irgendwas finde, worauf der Adapter "einrasten" kann. Oder aber die Spannungsversorgung ist nicht ganz astrein und wird beim Auslösen des Blitzes "verunreinigt". Dann sollten die Probleme aber auch häufiger sein...

Also - es bleibt spannend!

Sebi

Jörg_AC 23.10.2006 08:56

Hallo zusammen,
vielleicht macht es Sinn den Adapter mit einer vom Blitzgerät unabhängigen Spannung zu betreiben. Auf diese Art und Weise bleiben vielleicht einige unschöne Effekte die durch einbrechende Versorgungsspannung verursacht werden aus. Man müsste also intern die geschaltete Hauptspannung abzweigen. Oder aber extern für eine Alternative sorgen.
Ich habe zu meinem Dynax3000i Oberteil jetzt bei Ebay einen Hama Blitz 28dingsbums geschossen der den Fuß für einen externen Adapter liefern soll. Der Hama 28dingsbums ist zwar noch 100% OK und laut Beschreibung neuwertig aber aus irgendwelchen Gründen gingen die Defekten Blitze immer höher weg als die intakten....????
Naja mal sehen wie es sich weiter entwickelt.
Ich bin gespannt

Gruß

Jörg

sebi 24.10.2006 17:39

Zitat:

Zitat von Jörg_AC
Hallo zusammen,
vielleicht macht es Sinn den Adapter mit einer vom Blitzgerät unabhängigen Spannung zu betreiben. Auf diese Art und Weise bleiben vielleicht einige unschöne Effekte die durch einbrechende Versorgungsspannung verursacht werden aus. Man müsste also intern die geschaltete Hauptspannung abzweigen. Oder aber extern für eine Alternative sorgen.

Ich habe erstmal einen Elko und eine Diode eingebaut, damit ist die Versorgung um einiges stabiler und bricht vor allem nicht ein, wenn der Blitz nachgeladen wird. Das Problem der leeren Akkus sollte damit gelöst sein - ich habe gestern nach dem Umbau einen Akkusatz komplett leergelutscht - der Adapter hat klaglos funktioniert. Vorher hatte er tatsächlich nach dem Auslösen des Vorblitzes einige Daten verpennt - und damit natürlich Murks belichtet. Zusammen mit einigen Bugfixes am Code ist es mir nicht mehr gelungen, auf dem Blitzschuh eine Fehlbelichtung zu produzieren - was natürlich nichts heißen muß.:roll: Aber wir haben ja jetzt einen Betatester :cool:

Dafür hakt wireless mal wieder - aber ich bin dran!

Cheers,
Sebi

PeterHadTrapp 24.10.2006 17:44

Ah - klingt gut :!: und könnte auch der Grund für meine Fehlbelichtungen sein.

siehe PN.

PETER

sebi 25.10.2006 01:39

Nightly news...
 
Hallo miteinander,

es gibt mal wieder eine neue Version - flashconv-0.8

Mit dieser Version habe ich noch keine Fehlbelichtung "hinbekommen", wireless läuft ebenfalls wieder. Außerdem funktioniert diese Version ohne Änderungen mit dem XI und dem HS - es muß nur in der Datei const.h eingestellt werden, welcher Blitz es sein soll.

Jetzt muß nur der Betatester noch sein OK geben ;-)

Gute Nacht,
Sebi

PeterHadTrapp 25.10.2006 05:37

Alles wird gut :top:

:cool:

eichbaum08 25.10.2006 08:37

Hallo Sebi,

super Job.

Zwei Bitten hätte ich noch. Könntest du noch einen aktuellen Schaltplan einstellen und mit welchem Programm ist dein Programm komprimiert, die Endung *.tar kenne ich nicht?

Gruß Frank

Saludo 25.10.2006 08:59

Re: Nightly news...
 
Zitat:

Zitat von sebi
Mit dieser Version habe ich noch keine Fehlbelichtung "hinbekommen"

Hallo Sebi,

das hört sich verdammt gut an :top:

Denke der Einsatz eines Kondensators ist neben den Verbesserungen im Programm ein wichtiger Schritt.

Auch was Peter zu den sauber abgestimmten Belichtungen schrieb macht Mut. Mein Metz 54 MZ3 arbeitet zwar ganz ordentlich, aber perfekt ist er nicht.

Habe das Gefühl, mein alter 5400HS wird eines Tages mein Standartblitz. :D

Vieleicht kann Peter noch ein paar Beispielaunahmen unter verschiedenen Bedingungen einstellen.

Dein letztes Posting ist wieder von 02:39 Uhr :cool:

Alle Achtung - das nenne ich Biss :top:

Viele Grüße
Michael

sebi 25.10.2006 09:44

Zitat:

Zitat von eichbaum08
Hallo Sebi,

super Job.

Zwei Bitten hätte ich noch. Könntest du noch einen aktuellen Schaltplan einstellen und mit welchem Programm ist dein Programm komprimiert, die Endung *.tar kenne ich nicht?

Gruß Frank

Klar, Schaltplan gibt´s die Tage. Der größere Kondensator war ja schon eingezeichnet (ist der 47µF, den hatte ich schon mal drin, dann aber gedacht, er wäre überflüssig). Die Diode wird einfach in die Zuleitung geschaltet (vor den Kondensator) und verhindert, daß beim Einbrechen der Spannung die Ladung des Kondensators zur Spannungsquelle zurückfließt (also Kathode an den Kondensator, die Anode direkt an die Spannungsquelle).

Tar ist ein Archivierungstool aus der Unix-Welt. Die Datei sollte sich mit WinZIP etc. öffnen lassen. Ich werde mal ein Päckchen mit vorkompilierten Binärfiles schnüren - dann muß man keinen Compiler etc. installieren.

Sebi

jbr 25.10.2006 11:53

Auf Filzip ist ein kostenloser Zipper für Windows erhältlich der unter anderem auch mit tar (tape archive) Archiven umgehen kann.

Gruss
Jürgen

sebi 26.10.2006 00:09

Moin,

hier der versprochene Schaltplan:

http://www.d7userforum.de/phpBB2/4im.../flashconv.png

Gute Nacht,
Sebi

Jörg_AC 26.10.2006 09:13

So, habe gestern einen defekten SCA3301 bekommen und das Gehäuseoberteil einer defekten Dynax 3000i zurechtgesägt. Sieht aus als ob diese Kombination gewollt gewesen wäre. Passt wie Ar...h auf Eimer.
Als Spannungsversorgung: Tiny13 benötigt laut Spec 2,7 -5,5V dachte an 2 Lithium Knopfzellen mit je 3 V da könnte man dann mit einem Festspannungsregler 5V eine Konstante Versorgungsspannung herstellen.
Hmm dann mach ich mich nochmal auf die Suche nach der Minolta Blitzschuhbelegung, bestelle ein paar Teile bei Reichelt und .... wenn ich mal wieder dazu komme mache ich Feuer unter dem Lötkolben.


Jörg

sebi 26.10.2006 09:51

Hallo Jörg,

die Belegung ist hier im Thread irgendwo zu finden.

Du kannst es auch mit 3V probieren, der ATmega sollte auch damit anlaufen. Diode und Elko entfallen dann natürlich - es gibt ja bei Dir auch keine abzufangenden Schwankungen. Mit Diode kannst Du auch ohne Spannungsregler 2 Li-Zellen verwenden - bei 0,7V Abfall an der Diode läuft der ATtiny mit 5,3V - das paßt super. Einen Regler würde ich ohnehin nicht vorsehen - bei 1V Differenz hast Du mehr Verluste, als die Regelung bringt. Zudem müßte es ein lowdrop-Regler sein, alle anderen kommen mit <1V Differenz nicht klar.

Es sollte so auch eine Versorgung aus der Anschlußleitung des Blitzes möglich sein, das habe ich aber noch nicht probiert. Ich würde mal testweise Vcc über 1-10k mit CAM_FLASH verbinden (Diode und Elko müssen natürlich eingebaut sein, Elko vielleicht auch 100µF). Damit sollte der Blitz nicht auslösen, der Elko sich aber langsam aufladen um den ATtiny zu betreiben.

Insgesamt sollte man für die externe Variante aber mit den Stromsparmodi des ATtiny arbeiten. Bisher läuft der ATtiny durch, so verbraucht er ca. 6mA. Für die Versorgung aus dem Blitz finde ich das nicht dramatisch - im Vergleich zu den 5-10A, die der Blitz beim Aufladen zieht, sind das Peanuts. Aber für Batterieversorgung ist es ein bißchen viel. Legt man den Tiny schlafen, wenn nix passiert, geht der Verbrauch auf wenige µA zurück und man kann mit einer Li-Zelle Standby-Zeiten von mehreren Jahren erreichen. Da die externe Variante ja keine Wireless-Unterstützung bietet, bleibt auch Platz im Flash für den Code.

Viel Spaß beim Basteln,
Sebi

Jörg_AC 26.10.2006 11:58

Belegung gefunden
clock.. o
............ o data
GND... o
............ o fire

Bestellung bei Reich..lt
1/4W 10K Kohleschichtwiderstand 1/4W, 5%, 10 K-Ohm 0.100 €1
1N 4148 DIODE 0.020 € 1
ATTINY 13-20 DIP Atmel AVR-RISC-Controller 1.10 € 1
AX 47/16 Elko, axial, 47µF/16Volt 0.090 € 1
BR 2032 Lithium-Knopfzelle, 3 Volt, 180 mAh, 20,0x3,2mm 0.79 € 2
KZH 20-1 Knopfzellenhalter für Ø 20 mm 1.40 € 2
MKS-02 100N WIMA Folienkondensator, Rm 2,5mm 100nF 1
GS 8P IC-Sockel, 8-polig, superflach, gedreht, vergold. 0.090 € 1


Verstehe ich das richtig das GND und FIRE eins zu eins durchverbunden werden müssen und der Tiny13 nur zwischen clock und Data hängt.
VCC ist dann meine 6V von den Bakterien.
Benötige ich einen Tiny13 mit 10 oder 20 Mhz?
Gruß
Jörg

sebi 26.10.2006 12:09

Hallo Jörg,

es ist richtig, daß GND und FIRE durchverbunden sind. Die Fire-Leitung wird zwar beim Vorblitz und im wireless-Betrieb auch vom Tiny geschaltet, das verträgt die Dynax aber ohne Probleme (Fire wird nach dem Auslösen ohnehin vom Blitz auf low gehalten, bis er wieder aufgeladen ist).

Bei 2 Li-Zellen sicherheitshalber die Diode in die Zuleitung - 6V sollte zwar gehen, aber mit 5,3V bist Du auf der sicheren Seite lt. Datenblatt.

Der 100nF-Kondensator (WIMA Folie) ist etwas fett - ein billiger Keramik-Kondensator hätte genügt. Aber schaden tut´s nicht. Der Tiny wird mit dem internen 9,6MHz-Oszillator betrieben, die 10MHz-Variante würde reichen - aber auch der 20er tuts.

In der Datei "const.h" solltest Du "#define WIRELESS" in "// #define WIRLESS" ändern und damit die wireless-Unterstützung abschalten.

Wenn Du im Quellverzeichnis einfach "make flash" aufrufst, wird das Programm assembliert und in´s Flash geschrieben (ausgelegt für Parallelport-Adapter), außerdem werden die Fuses entsprechend gesetzt.

Und den Ein-Aus-Schalter nicht vergessen! Die Li-Zelle ist mit 180mAh angegeben - bei 6mA dürfte das 30h Dauerbetrieb entsprechen. Ohne Schalter ist das ein bißchen wenig, nur für´s Blitzen sollte es eine Weile reichen.

Sebi

Jörg_AC 26.10.2006 13:52

Ja Ein/Aus Schalter hab ich gleich mitbestellt.
Ein Parallelportkabel zur Programmierung werde ich wohl auch noch opfern können.
Wireless abschalten ist klar mein 5200i unterstützt ohnehin kein Wireless.
Mal sehen wie/ob er mit den Settings des 5400ers so klar kommt.

Zur Softwarekompilierung...
Kannst du da ein paar Worte mehr verlieren.
Ich habe zu Diplomarbeitszeiten mal mit MS Visual C++ rumgedocktert aber das ganze ist reichlich eingerostet. Gibt es da eine empfohlenen Compiler deinerseits? Ich denke ich komme nicht ganz drum herum selbst zu kompilieren da der 5200er sicher noch ein paar Anpassungen benötigt.

Danke

Jörg

artie 26.10.2006 15:06

Wireless Leitung ?
 
Hallo Sebi

Am Wochenende werd ich auch die Teile für den Umbau zusammen haben.
Eine Frage hab ich, hast du den Wireless Anschluss zum Attiny vom Blitz getrennt oder hat der Blitz auch noch eine Verbindung zum Wireless-Anschluss vom Empfänger?
Ich hab zum Glück auch das STK500 Board auch zur verfügung. Ich arbeite mit Bascom aber werde mit GCC noch bis zum Wochenende klarkommen. Wenn der Blitz umgebaut ist werde ich dir meine Ergebnisse mitteilen.
Bei der Blitzerrei werd ich mir eine Sonnenbrille aufsetzen :lol:

MFG

Arti

sebi 26.10.2006 18:23

Hallo,

@artie: Ich habe die Verbindung zum Blitz belassen und den Anschluß des ATtiny einfach mit aufgelötet. Damit sollte wireless sowohl mit analogen Kameras (Blitz im wireless-Mode, zeigt W.L.-1 an) als auch mit digitalen (Blitz muß unbedingt im normalen Modus sein!) funktionieren. Die Sonnenbrille ist eine gute Idee - ich habe ein paar versehentliche Auslösungen aus ca. 1m Entfernung "abgekriegt" - da sieht man schon ein wenig Sterne :cool:

@Jörg_AC:
Ich benutze den avr-gcc unter Linux. Es gibt aber natürlich auch eine Windows-Version (winavr), die läßt sich auch ins AVR-Studio integrieren. Leider habe ich damit keine Erfahrungen... Ich seh´s mir aber mal an.

Unter Linux muß man nur das Tarfile auspacken, in´s entstandene Verzeichnis wechseln und "make" eingeben, das startet die Assemblierung. "make clean" macht genau das ;-), "make flash" übersetzt und schreibt mittels avrdude auf den Tiny. "make realfuses" setzt außerdem die Fuses für wireless-Betrieb, setzt also auch die RSTDISBL-Fuse. Davon sollte man Abstand nehmen, solange nicht alles funktioniert.

Sebi

sebi 26.10.2006 18:57

Hallo nochmal,

hier eine Schritt-für-Schritt-Anleitung für WinAVR/AVRStudio unter Windows:

- AVR-Studio runterladen und installieren
- WinAVR ebenfalls runterladen und installieren
- flashconv-0.8.1 runterladen und auspacken. Diese Version enthält neben ein paar Bugfixes eine Projektdatei für AVRStudio.
- AVRStudio starten, "Project"->"Open" wählen und im flashconv-Verzeichnis die Datei flashconv.aps auswählen.

Unter "Build"->"Build" aufrufen (oder F7 drücken) - die Assemblierung läuft. Den danach angezeigten Fehler, daß das GCC-Plugin die Datei flashconv.elf nicht finden könnte, kann man ignorieren. Es gibt im Verzeichnis jetzt eine Datei "rom.hex", diese kann man mit AVRStudio auch gleich brennen.

Folgende Fuses müssen gesetzt sein (Haken drin im AVRStudio):
- Brown out detection level at VCC=2.7V (BODLEVEL=01)
- serial program downloading (SPI) enabled
- preserve eeprom memory through the chip erase cycle
- int. rc. osc. 9,6 MHz Startup-Time 14ck + 4ms (CKSEL=10 SUT=01)

Das sollte die Fuse-Bytes 0xfb, 0x36 ergeben. Wenn alles funktioniert und wireless aktiviert ist, muß auch bei "Reset disabled" ein Haken sein, die Fuses sind dann 0xfa, 0x36.

HTH,
Sebi

ManniC 26.10.2006 20:40

Meine volle Anerkennung sebi,
genau so hätte ich das auch geschrieben.... :cool:

Nee im Ernst: Ich verstehe nur Bahnhof :oops: , aber was hier abgeht ist einfach rundum Megaklasse :top: :top: :top:

eisenbahnschiene 26.10.2006 21:02

Zitat:

Zitat von ManniC
Meine volle Anerkennung sebi,
genau so hätte ich das auch geschrieben.... :cool:

Nee im Ernst: Ich verstehe nur Bahnhof :oops: , aber was hier abgeht ist einfach rundum Megaklasse :top: :top: :top:

So ungefähr wollte ich auch schon lange mal etwas zu dieser super Arbeit :top: :top: :top: schreiben. Auch ich verstehe nur Bahnhof und das obwohl ich mit einem Lötkolben umgehen kann und weiß was ne Diode und ein Kondensator ist.

Ich hoffe wie wahrscheinlich noch etliche andere stumme Mitleser dieses Threads, daß es irgendwann (hoffentlich schnell ;) ) einen programmierten Baustein zum Nachrüsten von einem arbeitswütigem Forumsmitglied zu kaufen gibt.

In diesem Sinne wünsche ich Sebi noch einen erfolgreichen Abend.

MfG

Olaf

sebi 27.10.2006 00:33

Hi Fans ;-)

Es ist Zeit für den täglichen Bericht.

Der Beta-Blitz von Peter ist gekommen und bereits modifiziert - d.h., die neueste Software ist eingespielt und der zusätzliche Kondensator nebst Diode sind eingebaut. Außerdem hat es sich gezeigt, daß für reibungslosen Drahtlos-Betrieb noch ein 10k-Widerstand von Vcc nach CAM_FIRE notwendig ist. Das alles ist drin, ich habe Testfotos drahtlos sowie auf dem Blitzschuh - mit Wechsel zwischen bouncen und direktem Blitzen etc. gemacht - nicht einen einzigen Aussetzer.

Die Abschaltung habe ich ebenfalls ausprobiert - wird die Kamera abgeschaltet, stellt sich der Blitz nach einigen Minuten automatisch ab. Sobald der Blitz einmal gültige wireless-Signale erhalten hat, wird die Abschaltung deaktiviert - bis man abschaltet oder ihn wieder auf dem Blitzschuh montiert.

Das Batterieproblem dürfte zumindest deutlich entschärft sein. Ich habe hier ein paar wirklich leere Alkaline-Mignons liegen (Aufladezeit nach Testblitz geht gegen 30s...). Damit habe ich Fehlbelichtungen provozieren können - wenn ich ausgelöst habe, obwohl der Blitz nach der vorigen Belichtung noch "gequietscht" hat. Ansonsten alles gut. Mit Akkus habe ich es gar nicht mehr geschafft - man darf gespannt sein.

Die Schnitzer der ersten Testrunde sollten also ausgemerzt sein. Morgen geht der Blitz an Peter raus, ich bin gespannt.

Aufgrund des überwältigenden Echos wird es definitiv eine fertige Platine zum Einbau geben. Das Layout für die Platine ist fertig, und mit dem frisch erworbenen Gewerbeschein sind auch die rechtlichen Voraussetzungen für den Vertrieb der bestückten Platinen erfüllt (schließlich leben wir in Deutschland, wo nix ohne Schein geht ;-)) Wann´s losgeht entscheidet sich vor allem nach den Tests; verlaufen die gut, könnten 4-8 Wochen realistisch sein. Definitiv ist allerdings schon die eMailadresse für Anfragen - blitzadapter@voitzsch.net (wer hätte das gedacht?!) :cool:

Trotzdem werden natürlich Quellcode, Schaltplan und - sobald getestet - auch das Platinenlayout frei verfügbar sein.

Den Frieden der Nacht wünscht
Sebi

PS: Preis? Keine Ahnung, 0<x<50 ;-)

PeterHadTrapp 27.10.2006 06:03

SEhr genial - Freue mich schon drauf.

:top: :top:
PETER

wutzel 27.10.2006 06:12

Hallo,
wollte auch meinen Respekt an sebi zollen :top: . Auf das die Preise für die Blitze explodieren.
Gruß
Daniel

PeterHadTrapp 27.10.2006 06:17

Vielleicht hätten wir den Thread hierverstecken sollen und nur mit zusätzlichem Passwort das von den Mods und von sebi händisch verteilt wird lesbar machen sollen. :twisted:

Mal sehen wie sich das auf die Preisentwicklung auswirkt. Anhaltspunkt: der 5400 HS erzielt meistesns Preise so um die 100 Euro, in der Regel etwas drunter oder drüber, aber nicht erheblich.

Bis jetzt verhalten sich die 5400HS-Preise noch unauffällig.

PETER


Alle Zeitangaben in WEZ +1. Es ist jetzt 14:21 Uhr.